port: run namespace tests only on Linux
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index e98f4b5714f414b5561cd3dc2cd308f9b933fdb2..a8642e931e4359e336135ef50c66a03d2e5c10a4 100644 (file)
@@ -1,21 +1,29 @@
-SUBDIRS = gen-ust-events \
-         gen-ust-events-ns \
+# SPDX-License-Identifier: GPL-2.0-only
+SUBDIRS = \
+         gen-ust-events \
          gen-ust-nevents \
          gen-ust-nevents-str \
          gen-ust-tracef \
          gen-syscall-events \
+         gen-kernel-test-events \
          userspace-probe-elf-binary
 
 if CXX_WORKS
 SUBDIRS += userspace-probe-elf-cxx-binary
 endif # CXX_WORKS
 
-if SDT_WORKS
+if TEST_SDT_UPROBE
 SUBDIRS += userspace-probe-sdt-binary
-endif # SDT_WORKS
+endif # TEST_SDT_UPROBE
 
 if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 SUBDIRS += gen-syscall-events-callstack
 endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 
+if IS_LINUX
+SUBDIRS += \
+         gen-ns-events \
+         gen-ust-events-ns
+endif # IS_LINUX
+
 noinst_HEADERS = signal-helper.h
This page took 0.023471 seconds and 4 git commands to generate.