Fix: Conditionally disable test requiring shared libs
[lttng-tools.git] / tests / ust / overlap / demo / Makefile.am
index 1532ecd7a4237d1bd8ea1e843709083c10c0431b..68b6e087f84f506aeaf9137e43bc659ad9f5f0c9 100644 (file)
@@ -1,5 +1,10 @@
 AM_CFLAGS=-I$(srcdir)
-
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+else
+# Force the shared flag on the noinst libraries since they are
+# only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
                                                   -rpath $(abs_builddir)
 
@@ -27,3 +32,7 @@ endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
 demo_LDADD = -lc
 endif
+
+noinst_SCRIPTS = demo-trace
+EXTRA_DIST = demo-trace
+endif
This page took 0.023356 seconds and 4 git commands to generate.