port: run namespace tests only on Linux
[lttng-tools.git] / tests / regression / Makefile.am
index 1d24a79663bf6d89d47b9a876fd77a3a5e82b3c9..c76a519de4ab382bffd3164b103357426656be7c 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 SUBDIRS = tools kernel ust
 
 LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
@@ -57,10 +59,14 @@ TESTS += ust/before-after/test_before_after \
        ust/blocking/test_blocking \
        ust/multi-lib/test_multi_lib \
        ust/rotation-destroy-flush/test_rotation_destroy_flush \
-       ust/namespaces/test_ns_contexts \
-       ust/namespaces/test_ns_contexts_change \
        tools/metadata/test_ust \
        tools/relayd-grouping/test_ust
+
+if IS_LINUX
+TESTS += \
+       ust/namespaces/test_ns_contexts \
+       ust/namespaces/test_ns_contexts_change
+endif # IS_LINUX
 endif # HAVE_LIBLTTNG_UST_CTL
 
 if PYTHON_BINDING
This page took 0.024216 seconds and 4 git commands to generate.