Bump lttng-ust protocol version to 6.1
authorJérémie Galarneau <jeremie.galarneau@efficios.com>
Thu, 14 Jan 2016 16:08:53 +0000 (11:08 -0500)
committerJérémie Galarneau <jeremie.galarneau@efficios.com>
Thu, 14 Jan 2016 16:31:55 +0000 (11:31 -0500)
The introduction of enumerations in lttng-ust forces the protocol
to accomodate a new command which will only be used by lttng-ust
2.8+.

This is not a breaking change in the protocol since lttng-tools
does not _need_ to receive this command for normal operation, nor
does it issue it.

Signed-off-by: Jérémie Galarneau <jeremie.galarneau@efficios.com>
src/bin/lttng-sessiond/lttng-ust-abi.h

index 40259cd81ee6fc714130511d16db16d589c56b7c..d4c3b60aa79508efe50c0433583ab64a8a86afe5 100644 (file)
@@ -45,7 +45,7 @@
 
 /* Version for ABI between liblttng-ust, sessiond, consumerd */
 #define LTTNG_UST_ABI_MAJOR_VERSION            6
-#define LTTNG_UST_ABI_MINOR_VERSION            0
+#define LTTNG_UST_ABI_MINOR_VERSION            1
 
 enum lttng_ust_instrumentation {
        LTTNG_UST_TRACEPOINT            = 0,
This page took 0.033687 seconds and 4 git commands to generate.