Fix: use LIBS instead of AM_LDFLAGS for dl and c linking
[lttng-tools.git] / tests / utils / testapp / gen-ust-nevents / Makefile.am
index e11b5f36f34fb8ff22c1eb0aa760cbb2885ad8c0..ace00160b2511cd98402a4196d3dfd8a7b711aca 100644 (file)
@@ -2,14 +2,14 @@ AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) -O2 -g
 AM_LDFLAGS =
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-nevents
 gen_ust_nevents_SOURCES = gen-ust-nevents.c tp.c tp.h
-gen_ust_nevents_LDADD = -llttng-ust
+gen_ust_nevents_LDADD = -llttng-ust -lurcu-bp
 endif
This page took 0.023487 seconds and 4 git commands to generate.