Use pkgconfig to detect and configure liblttng-ust
[lttng-tools.git] / tests / utils / testapp / gen-ust-nevents-str / Makefile.am
index 57f8350b42b1de51c95cf1540d6d9322837d39a7..0e961b4c4df3f4f86ef7e60f260ee0cec4565e8f 100644 (file)
@@ -1,16 +1,10 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) \
-               -I$(top_srcdir)/tests/utils -O2 -g
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-LIBS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-LIBS += -lc
-endif
+AM_CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils \
+       -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-nevents-str
 gen_ust_nevents_str_SOURCES = gen-ust-nevents-str.c tp.c tp.h
-gen_ust_nevents_str_LDADD = -llttng-ust -lurcu-bp \
-               $(top_builddir)/tests/utils/libtestutils.la
+gen_ust_nevents_str_LDADD = $(UST_LIBS) \
+               $(top_builddir)/tests/utils/libtestutils.la \
+               $(DL_LIBS)
 endif
This page took 0.026328 seconds and 4 git commands to generate.