Cleanup: Use pkg-config to detect liburcu
[lttng-tools.git] / tests / utils / testapp / gen-ust-events / Makefile.am
index 8918fc80d56cc6eca9fadd3a7acc9dc4e7c43202..4b1c2173bfc6e39a9be6cb2ed9a0afcf29621b65 100644 (file)
@@ -1,10 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(srcdir) \
        -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
-gen_ust_events_LDADD = $(UST_LIBS) -lurcu-bp \
+gen_ust_events_LDADD = $(UST_LIBS) $(URCU_BP_LIBS) \
                $(top_builddir)/tests/utils/libtestutils.la \
                $(DL_LIBS)
 endif
This page took 0.023766 seconds and 4 git commands to generate.