Cleanup: Use pkg-config to detect liburcu
[lttng-tools.git] / tests / utils / testapp / gen-ust-events / Makefile.am
index 0e726d11cedb97b448ebacb71e174ca7e95bea9c..4b1c2173bfc6e39a9be6cb2ed9a0afcf29621b65 100644 (file)
@@ -1,15 +1,12 @@
-AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(srcdir) -O2 -g
-AM_LDFLAGS =
+# SPDX-License-Identifier: GPL-2.0-only
 
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
-endif
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(srcdir) \
+       -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
-gen_ust_events_LDADD = -llttng-ust -lurcu-bp
+gen_ust_events_LDADD = $(UST_LIBS) $(URCU_BP_LIBS) \
+               $(top_builddir)/tests/utils/libtestutils.la \
+               $(DL_LIBS)
 endif
This page took 0.023012 seconds and 4 git commands to generate.