Use pkgconfig to detect and configure liblttng-ust
[lttng-tools.git] / tests / utils / testapp / gen-ust-events / Makefile.am
index 9700eac693a9f22707db392ade5228297da9748c..38e620d75274515d5635b5381013b199664595a1 100644 (file)
@@ -1,15 +1,10 @@
-AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(srcdir)
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-LIBS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-LIBS += -lc
-endif
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(srcdir) \
+       -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
-gen_ust_events_LDADD = -llttng-ust -lurcu-bp \
-               $(top_builddir)/tests/utils/libtestutils.la
+gen_ust_events_LDADD = $(UST_LIBS) \
+               $(top_builddir)/tests/utils/libtestutils.la \
+               $(DL_LIBS)
 endif
This page took 0.025729 seconds and 4 git commands to generate.