Add libconfig implementation and tests
[lttng-tools.git] / tests / unit / Makefile.am
index fa9c6a86c55726ce9eae06631be3b1ec5542c99a..ec8d22f620638f8580f60af1b99e48a6845f47a5 100644 (file)
@@ -1,3 +1,5 @@
+SUBDIRS = ini_config
+
 AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests/utils/ -I$(srcdir)
 AM_LDFLAGS =
 
@@ -17,7 +19,7 @@ LIBRELAYD=$(top_builddir)/src/common/relayd/librelayd.la
 
 # Define test programs
 noinst_PROGRAMS = test_uri test_session test_kernel_data
-noinst_PROGRAMS += test_utils_parse_size_suffix test_utils_resolve_relative test_utils_expand_path
+noinst_PROGRAMS += test_utils_parse_size_suffix test_utils_expand_path
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS += test_ust_data
@@ -92,11 +94,6 @@ test_utils_parse_size_suffix_SOURCES = test_utils_parse_size_suffix.c
 test_utils_parse_size_suffix_LDADD = $(LIBTAP) $(LIBHASHTABLE) $(LIBCOMMON)
 test_utils_parse_size_suffix_LDADD += $(UTILS_SUFFIX)
 
-# resolve_relative unit test
-test_utils_resolve_relative_SOURCES = test_utils_resolve_relative.c
-test_utils_resolve_relative_LDADD = $(LIBTAP) $(LIBHASHTABLE) $(LIBCOMMON)
-test_utils_resolve_relative_LDADD += $(UTILS_SUFFIX)
-
 # expand_path unit test
 test_utils_expand_path_SOURCES = test_utils_expand_path.c
 test_utils_expand_path_LDADD = $(LIBTAP) $(LIBHASHTABLE) $(LIBCOMMON)
This page took 0.023029 seconds and 4 git commands to generate.