Fix: use LIBS instead of AM_LDFLAGS for dl and c linking
[lttng-tools.git] / tests / regression / ust / high-throughput / Makefile.am
index 544640469df393feb7ed069564767311a615fe9f..25913c3f4695ffe40bbca44879f8e04b01cb39ef 100644 (file)
@@ -2,10 +2,10 @@ AM_CFLAGS = -I$(srcdir) -O2
 AM_LDFLAGS = -llttng-ust
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 noinst_PROGRAMS = gen-events
@@ -14,3 +14,17 @@ gen_events_LDADD = -llttng-ust
 
 noinst_SCRIPTS = test_high_throughput
 EXTRA_DIST = test_high_throughput
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024498 seconds and 4 git commands to generate.