Use pkgconfig to detect and configure liblttng-ust
[lttng-tools.git] / tests / regression / ust / exit-fast / Makefile.am
index ff47cd9dee56b7b78edfd8982633fcef7e0c3a09..c39dc9a44e3b129005ae72e5355e600d4aaac853 100644 (file)
@@ -1,15 +1,22 @@
-AM_CPPFLAGS = -I$(srcdir)
+AM_CPPFLAGS += -I$(srcdir)
 
 noinst_PROGRAMS = exit-fast
 exit_fast_SOURCES = exit-fast.c ust_tests_exitfast.h
-exit_fast_LDADD = -llttng-ust
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-exit_fast_LDADD += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-exit_fast_LDADD += -lc
-endif
+exit_fast_LDADD = $(UST_LIBS) $(DL_LIBS)
 
 noinst_SCRIPTS = test_exit-fast test_exit-fast.py
 EXTRA_DIST = test_exit-fast test_exit-fast.py
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024136 seconds and 4 git commands to generate.