Fix: tests: don't build dynamic lib tests if support disabled
[lttng-tools.git] / tests / regression / ust / clock-override / Makefile.am
index a656548de35c6cbff5abbf36777a94b84d38a06f..cc4b02c1eba69223f9f2f8839bfc7ea8abfe819a 100644 (file)
@@ -1,3 +1,14 @@
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+
+CLEANFILES = lttng-ust-clock-override-test.so \
+       lttng-ust-clock-override-test.so.debug
+
+EXTRA_DIST = test_clock_override lttng-ust-clock-override-test.c
+
+else
+
 AM_CPPFLAGS = -I$(srcdir)
 
 # The rpath is necessary because libtool won't build a shared library
@@ -19,8 +30,8 @@ if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
 lttng_ust_clock_override_test_la_LIBADD = -lc
 endif
 
-noinst_SCRIPTS = test_clock_override run-clock-override
-EXTRA_DIST = test_clock_override run-clock-override
+noinst_SCRIPTS = test_clock_override
+EXTRA_DIST = test_clock_override
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
@@ -35,3 +46,5 @@ clean-local:
                        rm -f $(builddir)/$$script; \
                done; \
        fi
+
+endif
This page took 0.024123 seconds and 4 git commands to generate.