Rename libcommon.so to libcommon-gpl.so
[lttng-tools.git] / tests / regression / tools / notification / Makefile.am
index 84e75d3070b056904c3bbe0df55c890b5de8bbbd..a59ee8d6daeb825e4e3e29c07f4f2bbad70f8831 100644 (file)
@@ -1,6 +1,6 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-AM_CFLAGS += -I$(top_srcdir)/tests/utils
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 LIB_LTTNG_CTL = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
@@ -12,9 +12,9 @@ if NO_SHARED
 CLEANFILES = libpause_consumer.so libpause_consumer.so.debug libpause_sessiond.so libpause_sessiond.so.debug
 EXTRA_DIST = \
             base_client.c \
-            consumer_testpoints.c \
-            sessiond_testpoints.c \
-            notification.c \
+            consumer_testpoints.cpp \
+            sessiond_testpoints.cpp \
+            notification.cpp \
             test_notification_kernel_buffer_usage \
             test_notification_kernel_capture \
             test_notification_kernel_error \
@@ -35,17 +35,17 @@ else
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
                           -rpath $(abs_builddir)
 
-libpause_consumer_la_SOURCES = consumer_testpoints.c
+libpause_consumer_la_SOURCES = consumer_testpoints.cpp
 libpause_consumer_la_LIBADD = \
        $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
-       $(top_builddir)/src/common/libcommon.la \
+       $(top_builddir)/src/common/libcommon-gpl.la \
        $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
        $(DL_LIBS)
 libpause_consumer_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
 
-libpause_sessiond_la_SOURCES = sessiond_testpoints.c
+libpause_sessiond_la_SOURCES = sessiond_testpoints.cpp
 libpause_sessiond_la_LIBADD = \
-       $(top_builddir)/src/common/libcommon.la \
+       $(top_builddir)/src/common/libcommon-gpl.la \
        $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
        $(DL_LIBS)
 libpause_sessiond_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
@@ -54,14 +54,16 @@ noinst_LTLIBRARIES = libpause_sessiond.la libpause_consumer.la
 base_client_SOURCES = base_client.c
 base_client_LDADD = $(LIB_LTTNG_CTL)
 
-notification_SOURCES = notification.c
+notification_SOURCES = notification.cpp
+# Tests the deprecated lttng_register_trigger() interface
+notification_CXXFLAGS = -Wno-deprecated-declarations $(AM_CXXFLAGS)
 notification_LDADD = $(LIB_LTTNG_CTL) $(LIBTAP) -lm
 
 rotation_SOURCES = rotation.c
 rotation_LDADD = $(LIB_LTTNG_CTL) $(LIBTAP) -lm
 
-default_pipe_size_getter_SOURCES = default_pipe_size_getter.c
-default_pipe_size_getter_LDADD = $(top_builddir)/src/common/libcommon.la
+default_pipe_size_getter_SOURCES = default_pipe_size_getter.cpp
+default_pipe_size_getter_LDADD = $(top_builddir)/src/common/libcommon-gpl.la
 
 noinst_SCRIPTS = \
        test_notification_kernel_buffer_usage \
This page took 0.024893 seconds and 4 git commands to generate.