Fix: use LIBS instead of AM_LDFLAGS for dl and c linking
[lttng-tools.git] / tests / regression / tools / live / Makefile.am
index 6551f13e698e81c469a169d356549a32026dc03f..24ccc7cfc194df56563a410e9ca71c2366cacbc9 100644 (file)
@@ -2,10 +2,10 @@ AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests/ut
 AM_LDFLAGS =
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
@@ -22,16 +22,17 @@ LIVE=$(top_builddir)/src/bin/lttng-sessiond/session.o \
         $(top_builddir)/src/bin/lttng-sessiond/snapshot.o
 
 noinst_PROGRAMS = live_test
-EXTRA_DIST = live_test test_kernel
+EXTRA_DIST = test_kernel test_lttng_kernel
 
 if HAVE_LIBLTTNG_UST_CTL
-EXTRA_DIST += test_ust
+EXTRA_DIST += test_ust test_ust_tracefile_count test_lttng_ust
 endif
 
 live_test_SOURCES = live_test.c
 live_test_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBRELAYD) $(LIBSESSIOND_COMM) \
-                                 $(LIBHASHTABLE) $(LIBHEALTH) -lrt -llttng-ctl
-live_test_LDADD += $(LIVE)
+                                 $(LIBHASHTABLE) $(LIBHEALTH) -lrt
+live_test_LDADD += $(LIVE) \
+                                  $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023721 seconds and 4 git commands to generate.