Fix: use LIBS instead of AM_LDFLAGS for dl and c linking
[lttng-tools.git] / tests / regression / tools / live / Makefile.am
index 167b9e6ad3765280de65a31c71b45b7450b04735..24ccc7cfc194df56563a410e9ca71c2366cacbc9 100644 (file)
@@ -2,10 +2,10 @@ AM_CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests/ut
 AM_LDFLAGS =
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
@@ -22,10 +22,10 @@ LIVE=$(top_builddir)/src/bin/lttng-sessiond/session.o \
         $(top_builddir)/src/bin/lttng-sessiond/snapshot.o
 
 noinst_PROGRAMS = live_test
-EXTRA_DIST = test_kernel
+EXTRA_DIST = test_kernel test_lttng_kernel
 
 if HAVE_LIBLTTNG_UST_CTL
-EXTRA_DIST += test_ust test_ust_tracefile_count
+EXTRA_DIST += test_ust test_ust_tracefile_count test_lttng_ust
 endif
 
 live_test_SOURCES = live_test.c
This page took 0.023825 seconds and 4 git commands to generate.