Fix: use LIBS instead of AM_LDFLAGS for dl and c linking
[lttng-tools.git] / tests / regression / tools / health / Makefile.am
index ed13743a41303970a7ea098ab651b035c6baf4ea..643dd31d2081b3deaba926d78575d26e3ee5770c 100644 (file)
@@ -2,10 +2,10 @@ AM_CFLAGS = -I. -O2 -g -I$(top_srcdir)/include
 AM_LDFLAGS =
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 if NO_SHARED
@@ -38,9 +38,9 @@ health_check_LDADD = $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la \
 endif
 
 dist_noinst_SCRIPTS = test_thread_exit test_thread_stall test_tp_fail \
-               test_health.sh
+               test_health.sh test_thread_ok
 EXTRA_DIST = test_thread_exit test_thread_stall test_tp_fail \
-               test_health.sh
+               test_health.sh test_thread_ok
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024217 seconds and 4 git commands to generate.