Tests: Ust getcpu override plugin
[lttng-tools.git] / tests / regression / Makefile.am
index 441354e12df708d979208f02def31437c7773142..53e3e43c2a19b3ee84dbe323e6307bce7dfd2510 100644 (file)
@@ -1,13 +1,21 @@
-SUBDIRS = . tools kernel
+SUBDIRS = tools kernel ust
 
-AM_CFLAGS = -g -Wall
-AM_LDFLAGS = -lurcu -lurcu-cds
-
-EXTRA_DIST = run-report.py test_list.py runall.sh
+EXTRA_DIST = run-report.py test_list.py
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
 endif # HAVE_LIBLTTNG_UST_CTL
 
-check-am:
-       ./runall.sh
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.02318 seconds and 4 git commands to generate.