Tests: add missing kernel test cases to make check target
[lttng-tools.git] / tests / regression / Makefile.am
index cc645fd740c512cd58493f992eb5be31464d6439..2aa5de8341a36c2b8aa07af0237326b40eab73aa 100644 (file)
@@ -4,36 +4,49 @@ SUBDIRS = tools kernel ust
 
 LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
 LOG_DRIVER = env PGREP='$(PGREP)' AM_TAP_AWK='$(AWK)' $(SHELL) \
-       $(top_srcdir)/config/tap-driver.sh
+       $(top_srcdir)/tests/utils/tap-driver.sh
 
-TESTS = tools/filtering/test_invalid_filter \
+TESTS = tools/base-path/test_ust \
+       tools/channel/test_channel \
+       tools/filtering/test_invalid_filter \
        tools/filtering/test_unsupported_op \
        tools/filtering/test_valid_filter \
+       tools/streaming/test_kernel \
        tools/streaming/test_ust \
        tools/health/test_thread_ok \
+       tools/live/test_kernel \
+       tools/live/test_lttng_kernel \
        tools/live/test_ust \
        tools/live/test_ust_tracefile_count \
        tools/live/test_lttng_ust \
        tools/tracefile-limits/test_tracefile_count \
        tools/tracefile-limits/test_tracefile_size \
        tools/exclusion/test_exclusion \
+       tools/snapshots/test_kernel \
        tools/snapshots/test_ust_fast \
        tools/snapshots/test_ust_streaming \
+       tools/snapshots/test_kernel_streaming \
        tools/save-load/test_save \
        tools/save-load/test_load \
        tools/save-load/test_autoload \
        tools/mi/test_mi \
        tools/wildcard/test_event_wildcard \
        tools/crash/test_crash \
+       tools/regen-metadata/test_kernel \
        tools/regen-metadata/test_ust \
+       tools/regen-statedump/test_kernel \
        tools/regen-statedump/test_ust \
        tools/notification/test_notification_ust_error \
        tools/notification/test_notification_ust_buffer_usage \
+       tools/notification/test_notification_ust_capture \
        tools/notification/test_notification_ust_event_rule_condition_exclusion \
        tools/notification/test_notification_kernel_error \
        tools/notification/test_notification_kernel_buffer_usage \
+       tools/notification/test_notification_kernel_capture \
        tools/notification/test_notification_kernel_instrumentation \
        tools/notification/test_notification_kernel_syscall \
+       tools/notification/test_notification_notifier_discarded_count \
+       tools/notification/test_notification_kernel_userspace_probe \
        tools/notification/test_notification_multi_app \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
@@ -41,13 +54,15 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/rotation/test_schedule_api \
        tools/metadata/test_kernel \
        tools/working-directory/test_relayd_working_directory \
-       tools/notification/test_notification_multi_app \
        tools/clear/test_ust \
        tools/clear/test_kernel \
        tools/tracker/test_event_tracker \
+       tools/trigger/start-stop/test_start_stop \
        tools/trigger/test_add_trigger_cli \
        tools/trigger/test_list_triggers_cli \
-       tools/trigger/test_remove_trigger_cli
+       tools/trigger/test_remove_trigger_cli \
+       tools/trigger/name/test_trigger_name_backwards_compat \
+       tools/trigger/hidden/test_hidden_trigger
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -68,7 +83,8 @@ TESTS += ust/before-after/test_before_after \
        ust/multi-lib/test_multi_lib \
        ust/rotation-destroy-flush/test_rotation_destroy_flush \
        tools/metadata/test_ust \
-       tools/relayd-grouping/test_ust
+       tools/relayd-grouping/test_ust \
+       tools/trigger/rate-policy/test_ust_rate_policy
 
 if IS_LINUX
 TESTS += \
This page took 0.023275 seconds and 4 git commands to generate.