Port: Detect platforms where librt is required
[lttng-tools.git] / src / common / Makefile.am
index c1b9d4e7a36f35d1e0c2b43712ba5b962ddbf044..e63ddeb73668f7a3cb6bb26a25e9d372b5b1ce36 100644 (file)
@@ -72,13 +72,17 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        pipe.c pipe.h readwrite.c readwrite.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
-                       sessiond-comm/unix.c sessiond-comm/unix.h \
+                       unix.c unix.h \
                        filter.c filter.h context.c context.h
 
 libcommon_la_LIBADD = \
-               -luuid \
-               -lrt \
                $(top_builddir)/src/common/config/libconfig.la
+if LTTNG_BUILD_WITH_LIBUUID
+libcommon_la_LIBADD += -luuid
+endif
+if LTTNG_BUILD_WITH_LIBC_UUID
+libcommon_la_LIBADD += -lc
+endif
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.02349 seconds and 4 git commands to generate.