sessiond: make functions static in ust-registry.c
[lttng-tools.git] / src / common / Makefile.am
index 896e2d6a1a458dedfa941baadf0a0c95405ac279..dc69f179a9e8c7da0182b8768450a6e2eafd874b 100644 (file)
@@ -6,7 +6,7 @@ SUBDIRS = string-utils
 # since SUBDIRS is decided at configure time.
 DIST_SUBDIRS = compat health hashtable kernel-ctl sessiond-comm relayd \
          kernel-consumer ust-consumer testpoint index config consumer \
-         string-utils
+         string-utils fd-tracker
 #
 # Common library
 noinst_LTLIBRARIES = libcommon.la
@@ -30,7 +30,8 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h runas.c \
                        userspace-probe.c event.c time.c \
                        session-descriptor.c credentials.h \
                        trace-chunk.c trace-chunk.h trace-chunk-registry.h \
-                       dynamic-array.h dynamic-array.c optional.h
+                       dynamic-array.h dynamic-array.c optional.h \
+                       uuid.c uuid.h
 
 if HAVE_ELF_H
 libcommon_la_SOURCES += lttng-elf.h lttng-elf.c
@@ -39,8 +40,7 @@ endif
 libcommon_la_LIBADD = \
                $(top_builddir)/src/common/config/libconfig.la \
                $(top_builddir)/src/common/compat/libcompat.la \
-               $(top_builddir)/src/common/hashtable/libhashtable.la \
-               $(UUID_LIBS)
+               $(top_builddir)/src/common/hashtable/libhashtable.la
 
 if BUILD_LIB_COMPAT
 SUBDIRS += compat
@@ -63,7 +63,7 @@ SUBDIRS += sessiond-comm
 endif
 
 if BUILD_LIB_RELAYD
-SUBDIRS += relayd
+SUBDIRS += relayd fd-tracker
 endif
 
 if BUILD_LIB_KERNEL_CONSUMER
This page took 0.023366 seconds and 4 git commands to generate.