Rename libcommon.so to libcommon-gpl.so
[lttng-tools.git] / src / common / Makefile.am
index 48e18f311c1f242ae5eff38d6e3767dc2178c39e..8cd93af44b2f02237cae292e528146cfcdcc02c6 100644 (file)
@@ -7,10 +7,12 @@ SUBDIRS = \
        bytecode \
        compat \
        config \
+       ini-config \
        fd-tracker \
        string-utils \
        filter \
-       hashtable
+       hashtable \
+       argpar-utils
 
 # Make sure to always distribute all folders
 # since SUBDIRS is decided at configure time.
@@ -26,18 +28,20 @@ DIST_SUBDIRS = \
        testpoint \
        index \
        config \
+       ini-config \
        consumer \
        string-utils \
        fd-tracker \
        bytecode \
        filter \
-       argpar
+       argpar \
+       argpar-utils
 
 # Common library
-noinst_LTLIBRARIES = libcommon.la
+noinst_LTLIBRARIES = libcommon-gpl.la
 EXTRA_DIST = mi-lttng-4.1.xsd
 
-libcommon_la_SOURCES = \
+libcommon_gpl_la_SOURCES = \
        actions/action.cpp \
        actions/list.cpp \
        actions/notify.cpp \
@@ -111,13 +115,14 @@ libcommon_la_SOURCES = \
        waiter.cpp waiter.h
 
 if HAVE_ELF_H
-libcommon_la_SOURCES += \
+libcommon_gpl_la_SOURCES += \
        lttng-elf.cpp lttng-elf.h
 endif
 
-libcommon_la_LIBADD = \
+libcommon_gpl_la_LIBADD = \
        $(top_builddir)/src/common/bytecode/libbytecode.la \
        $(top_builddir)/src/common/config/libconfig.la \
+       $(top_builddir)/src/common/ini-config/libini-config.la \
        $(top_builddir)/src/common/compat/libcompat.la \
        $(top_builddir)/src/common/hashtable/libhashtable.la \
        $(top_builddir)/src/common/fd-tracker/libfd-tracker.la \
@@ -177,7 +182,7 @@ noinst_HEADERS = \
 noinst_PROGRAMS = filter-grammar-test
 filter_grammar_test_SOURCES = filter-grammar-test.cpp
 filter_grammar_test_LDADD = \
-       libcommon.la
+       libcommon-gpl.la
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.024701 seconds and 4 git commands to generate.