consumerd: clean-up: stream attribute accessed without locking stream
[lttng-tools.git] / src / common / Makefile.am
index 1824fe46dcb601e561df0fea08b9e1c403ded65c..896e2d6a1a458dedfa941baadf0a0c95405ac279 100644 (file)
@@ -27,7 +27,10 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.h runas.c \
                        buffer-view.h buffer-view.c \
                        location.c \
                        waiter.h waiter.c \
-                       userspace-probe.c event.c
+                       userspace-probe.c event.c time.c \
+                       session-descriptor.c credentials.h \
+                       trace-chunk.c trace-chunk.h trace-chunk-registry.h \
+                       dynamic-array.h dynamic-array.c optional.h
 
 if HAVE_ELF_H
 libcommon_la_SOURCES += lttng-elf.h lttng-elf.c
@@ -35,6 +38,8 @@ endif
 
 libcommon_la_LIBADD = \
                $(top_builddir)/src/common/config/libconfig.la \
+               $(top_builddir)/src/common/compat/libcompat.la \
+               $(top_builddir)/src/common/hashtable/libhashtable.la \
                $(UUID_LIBS)
 
 if BUILD_LIB_COMPAT
@@ -87,7 +92,7 @@ endif
 
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                align.h bitfield.h bug.h time.h
+                                align.h bug.h time.h
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023238 seconds and 4 git commands to generate.