Create a dedicated test suite for Perf
[lttng-tools.git] / src / common / Makefile.am
index c1b9d4e7a36f35d1e0c2b43712ba5b962ddbf044..8619b5e25f31b627db462a128286ceb0a7872bd9 100644 (file)
@@ -61,7 +61,7 @@ AM_CFLAGS = -fno-strict-aliasing
 
 noinst_HEADERS = lttng-kernel.h defaults.h macros.h error.h futex.h \
                                 uri.h utils.h lttng-kernel-old.h \
-                                align.h bitfield.h bug.h
+                                align.h bitfield.h bug.h time.h
 
 # Common library
 noinst_LTLIBRARIES = libcommon.la
@@ -72,13 +72,17 @@ libcommon_la_SOURCES = error.h error.c utils.c utils.h runas.c runas.h \
                        pipe.c pipe.h readwrite.c readwrite.h \
                        mi-lttng.h mi-lttng.c \
                        daemonize.c daemonize.h \
-                       sessiond-comm/unix.c sessiond-comm/unix.h \
+                       unix.c unix.h \
                        filter.c filter.h context.c context.h
 
 libcommon_la_LIBADD = \
-               -luuid \
-               -lrt \
                $(top_builddir)/src/common/config/libconfig.la
+if LTTNG_BUILD_WITH_LIBUUID
+libcommon_la_LIBADD += -luuid
+endif
+if LTTNG_BUILD_WITH_LIBC_UUID
+libcommon_la_LIBADD += -lc
+endif
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.023463 seconds and 4 git commands to generate.