Add fd_handle interface
[lttng-tools.git] / src / common / Makefile.am
index 7ec0f52a50c7c0fe2ca5a55324cc0126617ec099..49e9a8fd8a478d0d691798fdeec77da3115620ea 100644 (file)
@@ -28,7 +28,12 @@ EXTRA_DIST = mi-lttng-4.0.xsd
 
 libcommon_la_SOURCES = \
        actions/action.c \
+       actions/group.c \
        actions/notify.c \
+       actions/rotate-session.c \
+       actions/snapshot-session.c \
+       actions/start-session.c \
+       actions/stop-session.c \
        buffer-usage.c \
        buffer-view.h buffer-view.c \
        common.h \
@@ -44,18 +49,22 @@ libcommon_la_SOURCES = \
        evaluation.c \
        event.c \
        filter.c filter.h \
+       fd-handle.c fd-handle.h \
        fs-handle.c fs-handle.h fs-handle-internal.h \
        futex.c futex.h \
        location.c \
        mi-lttng.c mi-lttng.h \
        notification.c \
        optional.h \
+       payload.c payload.h \
+       payload-view.c payload-view.h \
        pipe.c pipe.h \
        readwrite.c readwrite.h \
        runas.c runas.h \
        session-consumed-size.c \
        session-descriptor.c \
        session-rotation.c \
+       snapshot.c snapshot.h \
        spawn-viewer.c spawn-viewer.h \
        time.c \
        trace-chunk.c trace-chunk.h \
This page took 0.023497 seconds and 4 git commands to generate.