Move utils_expand_path and utils_expand_path_keep_symlink to libpath.la
[lttng-tools.git] / src / common / Makefile.am
index b7b59f95a9837615f2ec4d7dadd74e1325113d1c..1ac4874a02a5f50589a11e7a309167aef0dec50e 100644 (file)
@@ -38,7 +38,7 @@ DIST_SUBDIRS = \
        argpar-utils
 
 # Common library
-noinst_LTLIBRARIES = libcommon-lgpl.la libcommon-gpl.la
+noinst_LTLIBRARIES = libpath.la libcommon-lgpl.la libcommon-gpl.la
 EXTRA_DIST = mi-lttng-4.1.xsd
 
 # The libcommon-lgpl static archive contains only LGPLv2.1 code. It is
@@ -116,6 +116,12 @@ libcommon_lgpl_la_LIBADD = \
        $(top_builddir)/src/common/hashtable/libhashtable-lgpl.la \
        $(top_builddir)/src/vendor/msgpack/libmsgpack.la
 
+# The libpath static archive contains GPLv2 compatible code. It is
+# meant to be used by GPL executables.
+
+libpath_la_SOURCES = \
+       path.cpp path.h
+
 # The libcommon-gpl static archive contains GPLv2 compatible code. It is
 # meant to be used by GPL executables.
 
@@ -138,6 +144,7 @@ libcommon_gpl_la_SOURCES = \
 
 libcommon_gpl_la_LIBADD = \
        libcommon-lgpl.la \
+       libpath.la \
        $(top_builddir)/src/common/ini-config/libini-config.la \
        $(top_builddir)/src/common/hashtable/libhashtable-gpl.la \
        $(top_builddir)/src/common/fd-tracker/libfd-tracker.la
This page took 0.023222 seconds and 4 git commands to generate.