Add jul.c/.h to sessiond code
[lttng-tools.git] / src / bin / lttng-sessiond / Makefile.am
index 26a2d13a0cac2be8fb7438297ceac88434e33684..21b58591056512bae0f7ccedd66cb2dd0169b790 100644 (file)
@@ -10,6 +10,7 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        trace-kernel.c trace-kernel.h \
                        kernel.c kernel.h \
                        ust-ctl.h ust-app.h trace-ust.h ust-thread.h \
+                       ust-registry.h \
                        context.c context.h \
                        channel.c channel.h \
                        event.c event.h \
@@ -21,12 +22,15 @@ lttng_sessiond_SOURCES = utils.c utils.h \
                        fd-limit.c fd-limit.h \
                        kernel-consumer.c kernel-consumer.h \
                        consumer.h \
-                       health.c health.h \
+                       health-sessiond.h \
                        cmd.c cmd.h \
-                       testpoint.h
+                       buffer-registry.c buffer-registry.h \
+                       testpoint.h ht-cleanup.c \
+                       snapshot.c snapshot.h \
+                       jul.c jul.h
 
 if HAVE_LIBLTTNG_UST_CTL
-lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-registry.h ust-app.c \
+lttng_sessiond_SOURCES += trace-ust.c ust-registry.c ust-app.c \
                        ust-consumer.c ust-consumer.h ust-thread.c \
                        ust-metadata.c ust-clock.h
 endif
@@ -43,7 +47,8 @@ lttng_sessiond_LDADD = -lrt -lurcu-common -lurcu \
                $(top_builddir)/src/common/libcommon.la \
                $(top_builddir)/src/common/compat/libcompat.la \
                $(top_builddir)/src/common/relayd/librelayd.la \
-               $(top_builddir)/src/common/testpoint/libtestpoint.la
+               $(top_builddir)/src/common/testpoint/libtestpoint.la \
+               $(top_builddir)/src/common/health/libhealth.la
 
 if HAVE_LIBLTTNG_UST_CTL
 lttng_sessiond_LDADD += -llttng-ust-ctl
This page took 0.023117 seconds and 4 git commands to generate.