Cleanup: Use pkg-config to detect liburcu
[lttng-tools.git] / src / bin / lttng-relayd / Makefile.am
index c950be385784d9bbd0df75a10db52d1fece0f901..f6d5b29501f17295dcc9fc1e0e8641b502be6710 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
        -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
@@ -26,10 +28,10 @@ lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
                        backward-compatibility-group-by.c backward-compatibility-group-by.h
 
 # link on liblttngctl for check if relayd is already alive.
-lttng_relayd_LDADD = -lurcu-common -lurcu \
+lttng_relayd_LDADD = $(URCU_LIBS) \
+               $(top_builddir)/src/common/libcommon.la \
                $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la \
                $(top_builddir)/src/common/hashtable/libhashtable.la \
-               $(top_builddir)/src/common/libcommon.la \
                $(top_builddir)/src/common/compat/libcompat.la \
                $(top_builddir)/src/common/index/libindex.la \
                $(top_builddir)/src/common/health/libhealth.la \
This page took 0.023232 seconds and 4 git commands to generate.