Extend the rotation API to provide network trace archive locations
[lttng-tools.git] / src / bin / lttng-relayd / Makefile.am
index 31859b564cba54be4b3ff2c882d50e283b3a2923..5125c72195acf75545d9e155647fe94a974ac2f7 100644 (file)
@@ -1,13 +1,10 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src \
-                         -DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
-                         -DINSTALL_LIB_PATH=\""$(libdir)"\"
+AM_CPPFLAGS += -DINSTALL_BIN_PATH=\""$(lttnglibexecdir)"\" \
+       -DINSTALL_LIB_PATH=\""$(libdir)"\"
 
 if EMBED_HELP
 AM_CPPFLAGS += -I$(top_builddir)/doc/man
 endif
 
-AM_CFLAGS = -fno-strict-aliasing
-
 bin_PROGRAMS = lttng-relayd
 
 lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
@@ -24,7 +21,8 @@ lttng_relayd_SOURCES = main.c lttng-relayd.h utils.h utils.c cmd.h \
                        stream-fd.c stream-fd.h \
                        connection.c connection.h \
                        viewer-session.c viewer-session.h \
-                       tracefile-array.c tracefile-array.h
+                       tracefile-array.c tracefile-array.h \
+                       tcp_keep_alive.c tcp_keep_alive.h
 
 # link on liblttngctl for check if relayd is already alive.
 lttng_relayd_LDADD = -lurcu-common -lurcu \
This page took 0.023897 seconds and 4 git commands to generate.