Add --disable-git-version to configure
[lttng-tools.git] / include / Makefile.am
index cbd8861fc83bd6a8d82fa74b38a038b139c9cccb..d2061f1e05ea75bb7db8fd542dc683d19253bdca 100644 (file)
@@ -46,20 +46,8 @@ version.h:
                        ## as the one currently in the file (if there is one), as we
                        ## don't want to update the file if it is already up to date
                        ##
-                       if [ $$(grep -cE "^#define GIT_VERSION \"?$${git_version}\"?$$" "$${version_h}") -eq 0 ]; then \
-                               if [ $$(grep -c "^#define GIT_VERSION" "$${version_h}") -gt 0 ]; then \
-                                       ##
-                                       ## If there is already a GIT_VERSION defined,
-                                       ## we just replace it by the new version
-                                       ##
-                                       sed -i "s'^#define GIT_VERSION.*$$'#define GIT_VERSION \"$${git_version}\"'" "$${version_h}"; \
-                               else \
-                                       ##
-                                       ## Else, we add a GIT_VERSION define
-                                       ## containing our new version.
-                                       ##
-                                       sed -i "s'^\(#define VERSION_H.*\)$$'\1\n\n#define GIT_VERSION \"$${git_version}\"'" "$${version_h}"; \
-                               fi; \
+                       if [ $$(grep -cE "^#define GIT_VERSION_SED \"?$${git_version}\"?$$" "$${version_h}") -eq 0 ]; then \
+                               sed -i "s'^#define GIT_VERSION_SED.*$$'#define GIT_VERSION \"$${git_version}\"'" "$${version_h}"; \
                        fi; \
                fi; \
        fi)
@@ -83,9 +71,11 @@ lttnginclude_HEADERS = \
        lttng/lttng-error.h \
        lttng/snapshot.h \
        lttng/save.h \
+       lttng/load.h \
        version.h
 
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
        lttng/health-internal.h \
-       lttng/save-internal.h
+       lttng/save-internal.h \
+       lttng/load-internal.h
This page took 0.023131 seconds and 4 git commands to generate.