doc/man: use configured directories in man pages
[lttng-tools.git] / doc / man / Makefile.am
index d8882028a594bcc15b2f650b0184e50401774ca0..3cd3effc668723ca75e38ca9c0e75fc7387bfe94 100644 (file)
@@ -1,5 +1,4 @@
-# Man pages are only built if the --enable-man-pages option was
-# passed to the configure script.
+# Man pages are only built if they are enabled at configure time.
 #
 # They should always be built before creating a distribution tarball.
 
@@ -78,7 +77,9 @@ if MAN_PAGES_OPT
 if HAVE_ASCIIDOC_XMLTO
 # tools
 ADOC = $(ASCIIDOC) -f $(ASCIIDOC_CONF) -d manpage \
-       -a lttng_version="$(PACKAGE_VERSION)"
+       -a lttng_version="$(PACKAGE_VERSION)" \
+       -a system_sessions_dir="$(sysconfdir)/lttng/sessions" \
+       -a system_lttng_conf="$(sysconfdir)/lttng/lttng.conf"
 ADOC_DOCBOOK = $(ADOC) -b docbook
 XTO = $(XMLTO) -m $(firstword $(XSL_SRC_FILES)) man
 
@@ -135,5 +136,11 @@ dist_man3_MANS += $(MAN3)
 dist_man8_MANS += $(MAN8)
 endif # MAN_PAGES_OPT
 
+if !MAN_PAGES_OPT
+dist-hook:
+       @echo "Error: Please enable the man pages before creating a distribution tarball."
+       @false
+endif # !MAN_PAGES_OPT
+
 # always distribute the source files
 EXTRA_DIST = $(MAN_TXT) $(COMMON_TXT) $(XSL_SRC_FILES) $(ASCIIDOC_CONF)
This page took 0.023297 seconds and 4 git commands to generate.