prepare the 0.3 release
[lttngtop.git] / configure.ac
1 # -*- Autoconf -*-
2 # Process this file with autoconf to produce a configure script.
3
4 AC_INIT([lttngtop],[0.3],[jdesfossez@efficios.com])
5 AC_CONFIG_AUX_DIR([config])
6 AC_CANONICAL_TARGET
7 AC_CANONICAL_HOST
8 AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip])
9 AM_SILENT_RULES([yes])
10
11 AC_CONFIG_MACRO_DIR([m4])
12
13 AC_CONFIG_HEADERS([config.h])
14
15 # Checks for programs.
16 AC_PROG_CC
17 AC_PROG_MAKE_SET
18 LT_INIT
19 AC_PROG_YACC
20 AC_PROG_LEX
21
22 # Checks for typedefs, structures, and compiler characteristics.
23 AC_C_INLINE
24 AC_TYPE_PID_T
25 AC_TYPE_SIZE_T
26
27 # Checks for library functions.
28 AC_FUNC_MALLOC
29 AC_FUNC_MMAP
30 AC_CHECK_FUNCS([bzero gettimeofday munmap strtoul])
31
32 # Check for libuuid
33 AC_CHECK_LIB([uuid], [uuid_generate], [],
34 [AC_MSG_ERROR([Cannot find the libuuid library.])]
35 )
36
37 # Check for libpopt
38 AC_CHECK_LIB([popt], [poptGetContext], [],
39 [AC_MSG_ERROR([Cannot find the popt library.])]
40 )
41
42 # Check for libncurses
43 AC_CHECK_LIB([ncurses], [initscr], [], [HAVE_NCURSES=0]
44 )
45
46 # Check for libpanel, also part of libncurses
47 # (but this check will add the required -lpanel flag)
48 AC_CHECK_LIB([panel], [update_panels], [], [HAVE_PANELS=0]
49 )
50
51 # Check for libbabeltrace
52 AC_CHECK_LIB([babeltrace], [bt_context_create], [],
53 [AC_MSG_ERROR([Cannot find the babeltrace library.])]
54 )
55
56 # Check for libbabeltrace-ctf
57 AC_CHECK_LIB([babeltrace-ctf], [bt_ctf_iter_create], [],
58 [AC_MSG_ERROR([Cannot find the babeltrace-ctf library.])]
59 )
60
61 # Check for Glib. It needs to be installed anyway or this macro will not be defined.
62 AM_PATH_GLIB_2_0([2.22.0], [],
63 [AC_MSG_ERROR([Glib 2.22 is required in order to compile LTTngTop.
64 Please install the Glib development files.])], [gmodule]
65 )
66
67 pkg_modules="gmodule-2.0 >= 2.0.0"
68 PKG_CHECK_MODULES(GMODULE, [$pkg_modules])
69 AC_SUBST(PACKAGE_LIBS)
70 LIBS="$LIBS $GMODULE_LIBS"
71
72 PACKAGE_CFLAGS="$GMODULE_CFLAGS -Wall -Werror=format-security"
73 AC_SUBST(PACKAGE_CFLAGS)
74
75 AC_CONFIG_FILES([
76 Makefile
77 src/Makefile
78 doc/Makefile
79 utils/Makefile
80 ])
81 AC_OUTPUT
82
83 AS_IF([test "x$HAVE_NCURSES" = "x0"],[
84 AS_ECHO()
85 AS_ECHO_N("Ncurses GUI won't be compiled install ncurses if you want it.")
86 ], [
87 CURSES_LIBS="-lcurses -lpanel"
88 AC_SUBST(CURSES_LIBS)
89 AS_ECHO()
90 AS_ECHO_N("Ncurses GUI will be compiled.")
91 ])
92 AS_ECHO()
93
This page took 0.041839 seconds and 4 git commands to generate.