Add UST version validation
authorDavid Goulet <dgoulet@efficios.com>
Mon, 23 Jan 2012 17:01:35 +0000 (12:01 -0500)
committerDavid Goulet <dgoulet@efficios.com>
Mon, 23 Jan 2012 17:01:35 +0000 (12:01 -0500)
commite0c7ec2b3d96dd7ddd9375c5f72239a733d0cf24
tree483ddb9ecee02defab37993d4600c5195d488ff0
parentd8e76ef6aa9d28ff287ec6d201c6e2be37181554
Add UST version validation

Upon registration of an UST app, we now check the version compatibility
with the session daemon and set a compatible bit. Only the major version
is validated since major version bump implies ABI/API breakage.

For now, every action on the application list check the app compatible
bit before executing it. We are too close from a stable release so hard
*not standard* check is done across the map for ust-app. The downside is
that the client will not get informed of any incompatible app upon any
action on the tracer using lttng cli.

If the version is NOT compatible, the register done is sent and the app
is kept in the registry. We can't close the socket or deny the
registration because if the env. var LTTNG_UST_REGISTER_TIMEOUT=-1 is
set on the app side, infinite loop will occur and possibly stall the
app.

New sessiond comm. version error added but not use at this commit.

Signed-off-by: David Goulet <dgoulet@efficios.com>
src/bin/lttng-sessiond/main.c
src/bin/lttng-sessiond/ust-app.c
src/bin/lttng-sessiond/ust-app.h
src/common/sessiond-comm/sessiond-comm.c
src/common/sessiond-comm/sessiond-comm.h
This page took 0.03242 seconds and 4 git commands to generate.