tests: compile some tools/tests as C++
[lttng-tools.git] / tests / utils / testapp / gen-ust-events / Makefile.am
index d6327d5b22d16498765e2e60cd31769857f15667..c05c665a1e0127a3616057e649f73cebb0bd5f34 100644 (file)
@@ -5,8 +5,11 @@ AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(srcdir) \
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS = gen-ust-events
-gen_ust_events_SOURCES = gen-ust-events.c tp.c tp.h
-gen_ust_events_LDADD = $(UST_LIBS) -lurcu-bp \
+gen_ust_events_SOURCES = \
+       gen-ust-events.cpp \
+       tp.c \
+       tp.h
+gen_ust_events_LDADD = $(UST_LIBS) \
                $(top_builddir)/tests/utils/libtestutils.la \
                $(DL_LIBS)
 endif
This page took 0.022827 seconds and 4 git commands to generate.