Tests: add UST namespace context change tests
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index 84113a23c3176dd5f975f59f90cae3ce18ff7e62..e98f4b5714f414b5561cd3dc2cd308f9b933fdb2 100644 (file)
@@ -1,2 +1,21 @@
-SUBDIRS = gen-ust-events gen-ust-nevents gen-ust-nevents-str gen-ust-tracef
+SUBDIRS = gen-ust-events \
+         gen-ust-events-ns \
+         gen-ust-nevents \
+         gen-ust-nevents-str \
+         gen-ust-tracef \
+         gen-syscall-events \
+         userspace-probe-elf-binary
 
+if CXX_WORKS
+SUBDIRS += userspace-probe-elf-cxx-binary
+endif # CXX_WORKS
+
+if SDT_WORKS
+SUBDIRS += userspace-probe-sdt-binary
+endif # SDT_WORKS
+
+if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+SUBDIRS += gen-syscall-events-callstack
+endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+
+noinst_HEADERS = signal-helper.h
This page took 0.023144 seconds and 4 git commands to generate.