Tests: add UST namespace context change tests
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index 596591265c1799567c5e95a44f2e737169582e00..e98f4b5714f414b5561cd3dc2cd308f9b933fdb2 100644 (file)
@@ -1,3 +1,21 @@
-SUBDIRS = gen-ust-events gen-ust-nevents gen-ust-nevents-str gen-ust-tracef gen-syscall-events
+SUBDIRS = gen-ust-events \
+         gen-ust-events-ns \
+         gen-ust-nevents \
+         gen-ust-nevents-str \
+         gen-ust-tracef \
+         gen-syscall-events \
+         userspace-probe-elf-binary
+
+if CXX_WORKS
+SUBDIRS += userspace-probe-elf-cxx-binary
+endif # CXX_WORKS
+
+if SDT_WORKS
+SUBDIRS += userspace-probe-sdt-binary
+endif # SDT_WORKS
+
+if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+SUBDIRS += gen-syscall-events-callstack
+endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 
 noinst_HEADERS = signal-helper.h
This page took 0.023578 seconds and 4 git commands to generate.