Rename C++ header files to .hpp
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index e54ac890aee31ffc7a3562ee22add1adf9d27c68..55a7ba7ebddb055b0f61346a9ee8e69abb433091 100644 (file)
@@ -1,20 +1,27 @@
-SUBDIRS = gen-ust-events \
+# SPDX-License-Identifier: GPL-2.0-only
+SUBDIRS = \
+         gen-kernel-test-events \
+         gen-py-events \
+         gen-syscall-events \
+         gen-ust-events \
          gen-ust-nevents \
          gen-ust-nevents-str \
          gen-ust-tracef \
-         gen-syscall-events \
-         userspace-probe-elf-binary
+         userspace-probe-elf-binary \
+         userspace-probe-elf-cxx-binary
 
-if CXX_WORKS
-SUBDIRS += userspace-probe-elf-cxx-binary
-endif # CXX_WORKS
-
-if SDT_WORKS
+if TEST_SDT_UPROBE
 SUBDIRS += userspace-probe-sdt-binary
-endif # SDT_WORKS
+endif # TEST_SDT_UPROBE
 
 if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 SUBDIRS += gen-syscall-events-callstack
 endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 
-noinst_HEADERS = signal-helper.h
+if IS_LINUX
+SUBDIRS += \
+         gen-ns-events \
+         gen-ust-events-ns
+endif # IS_LINUX
+
+noinst_HEADERS = signal-helper.hpp
This page took 0.023506 seconds and 4 git commands to generate.