Rename C++ header files to .hpp
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index e2ad1f2355f6c1f4a3c2fab8a8821d8a98526f5f..55a7ba7ebddb055b0f61346a9ee8e69abb433091 100644 (file)
@@ -1,16 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
 SUBDIRS = \
-         gen-ns-events \
+         gen-kernel-test-events \
+         gen-py-events \
+         gen-syscall-events \
          gen-ust-events \
-         gen-ust-events-ns \
          gen-ust-nevents \
          gen-ust-nevents-str \
          gen-ust-tracef \
-         gen-syscall-events \
-         userspace-probe-elf-binary
-
-if CXX_WORKS
-SUBDIRS += userspace-probe-elf-cxx-binary
-endif # CXX_WORKS
+         userspace-probe-elf-binary \
+         userspace-probe-elf-cxx-binary
 
 if TEST_SDT_UPROBE
 SUBDIRS += userspace-probe-sdt-binary
@@ -20,4 +18,10 @@ if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 SUBDIRS += gen-syscall-events-callstack
 endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
 
-noinst_HEADERS = signal-helper.h
+if IS_LINUX
+SUBDIRS += \
+         gen-ns-events \
+         gen-ust-events-ns
+endif # IS_LINUX
+
+noinst_HEADERS = signal-helper.hpp
This page took 0.023344 seconds and 4 git commands to generate.