Fix: support VPATH build for tests
[lttng-tools.git] / tests / utils / tap / Makefile.am
index 366f4c4a566bf6b61a9fac0213cad85d6cd0ff99..0e78398feea29b5d359a910048648cb5d38d1074 100644 (file)
@@ -1,2 +1,18 @@
-lib_LTLIBRARIES = libtap.la
+noinst_LTLIBRARIES = libtap.la
 libtap_la_SOURCES = tap.c tap.h
+dist_noinst_SCRIPTS = tap.sh
+EXTRA_DIST = tap.sh
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023192 seconds and 4 git commands to generate.