buffer-view: introduce lttng_buffer_view_contains_string
[lttng-tools.git] / tests / unit / Makefile.am
index 09de39e8cc99d3a22ee4378cc340484ad12e35a9..e2c57bc8e7d68b28c1b0c3e08c18cd3cec06ce0e 100644 (file)
@@ -21,7 +21,8 @@ TESTS = test_kernel_data \
        test_relayd_backward_compat_group_by_session \
        ini_config/test_ini_config \
        test_fd_tracker \
-       test_uuid
+       test_uuid \
+       test_buffer_view
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
@@ -39,7 +40,8 @@ noinst_PROGRAMS = test_uri test_session test_kernel_data \
                   test_utils_expand_path test_utils_compat_poll \
                   test_string_utils test_notification test_directory_handle \
                   test_relayd_backward_compat_group_by_session \
-                  test_fd_tracker test_uuid
+                  test_fd_tracker test_uuid \
+                  test_buffer_view
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS += test_ust_data
@@ -195,3 +197,7 @@ test_fd_tracker_LDADD = $(LIBTAP) $(LIBFDTRACKER) $(DL_LIBS) -lurcu $(LIBCOMMON)
 # uuid unit test
 test_uuid_SOURCES = test_uuid.c
 test_uuid_LDADD = $(LIBTAP) $(LIBCOMMON)
+
+# buffer view unit test
+test_buffer_view_SOURCES = test_buffer_view.c
+test_buffer_view_LDADD = $(LIBTAP) $(LIBCOMMON)
This page took 0.023026 seconds and 4 git commands to generate.