Rename firing policy to rate policy
[lttng-tools.git] / tests / unit / Makefile.am
index 5cf4d31ca37fa7fd1541bc75912c295a1377bc78..2a0f3c9fb6a6c231079a0b937ff439bc1a7894b8 100644 (file)
@@ -10,12 +10,13 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
 
 TESTS = \
        ini_config/test_ini_config \
+       test_action \
        test_buffer_view \
        test_directory_handle \
        test_event_expr_to_bytecode \
        test_event_rule \
        test_fd_tracker \
-       test_firing_policy \
+       test_rate_policy \
        test_kernel_data \
        test_kernel_probe \
        test_log_level_rule \
@@ -45,13 +46,14 @@ LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 # Define test programs
 noinst_PROGRAMS = \
+       test_action \
        test_buffer_view \
        test_condition \
        test_directory_handle \
        test_event_expr_to_bytecode \
        test_event_rule \
        test_fd_tracker \
-       test_firing_policy \
+       test_rate_policy \
        test_kernel_data \
        test_kernel_probe \
        test_log_level_rule \
@@ -232,9 +234,9 @@ test_relayd_backward_compat_group_by_session_SOURCES = test_relayd_backward_comp
 test_relayd_backward_compat_group_by_session_LDADD = $(LIBTAP) $(LIBCOMMON) $(RELAYD_OBJS)
 test_relayd_backward_compat_group_by_session_CPPFLAGS = $(AM_CPPFLAGS) -I$(top_srcdir)/src/bin/lttng-relayd
 
-# firing policy object unit test
-test_firing_policy_SOURCES = test_firing_policy.c
-test_firing_policy_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS) \
+# rate policy object unit test
+test_rate_policy_SOURCES = test_rate_policy.c
+test_rate_policy_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS) \
                      $(top_builddir)/src/bin/lttng/lttng-loglevel.$(OBJEXT)
 
 # fd tracker unit test
@@ -268,3 +270,7 @@ test_event_expr_to_bytecode_LDADD = $(LIBTAP) $(LIBLTTNG_CTL) $(LIBCOMMON)
 # Log level rule api
 test_log_level_rule_SOURCES = test_log_level_rule.c
 test_log_level_rule_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
+
+# Action api
+test_action_SOURCES = test_action.c
+test_action_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
This page took 0.023958 seconds and 4 git commands to generate.