Enforce DL_LIBS value instead of hard coded -ldl
[lttng-tools.git] / tests / regression / ust / ust-dl / Makefile.am
index 315a995afdf512a26b448b7d2988a8f90e2fa692..c51e072fc62efedd157c2a25aa9881c54e9ca319 100644 (file)
@@ -19,7 +19,7 @@ AM_CPPFLAGS += -I$(srcdir) -g
 
 noinst_PROGRAMS = prog
 prog_SOURCES = prog.c
-prog_LDADD = -ldl
+prog_LDADD = $(DL_LIBS)
 
 noinst_LTLIBRARIES = libzzz.la libbar.la libfoo.la libtp.la
 
@@ -67,7 +67,7 @@ libtp.so: libtp.la
        @cp -f .libs/libtp.so libtp.so
 
 noinst_SCRIPTS = test_ust-dl test_ust-dl.py
-EXTRA_DIST = test_ust-dl test_ust-dl.py
+EXTRA_DIST = test_ust-dl.py
 
 all-local: libfoo.so libbar.so libzzz.so libtp.so
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.02389 seconds and 4 git commands to generate.