vscode: Add configurations to run the executables under the debugger
[lttng-tools.git] / tests / regression / ust / nprocesses / Makefile.am
index 63a320954c06e1e754c63211526a80dc9842f6c8..39f0e6ac8cc7693bec140132fb596c553320dd29 100644 (file)
@@ -1,16 +1,18 @@
-AM_CFLAGS = -I$(srcdir) -O2
-AM_LDFLAGS = -llttng-ust
+# SPDX-License-Identifier: GPL-2.0-only
 
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
-endif
+noinst_SCRIPTS = test_nprocesses
+EXTRA_DIST = test_nprocesses
 
-noinst_PROGRAMS = gen-events-time
-gen_events_time_SOURCES = gen-events-time.c tp.c ust_gen_event.h
-gen_events_time_LDADD = -llttng-ust
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-noinst_SCRIPTS = test_nprocesses ust-nprocesses
-EXTRA_DIST = test_nprocesses ust-nprocesses
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023765 seconds and 4 git commands to generate.