Refactor: test: wrapper for destroy_lttng_session
[lttng-tools.git] / tests / regression / ust / low-throughput / Makefile.am
index e62706007a2b097af442fc6adbe676cfe58e8ee6..630d797b38f6493e25e0037a8397fdaeaad2dec2 100644 (file)
@@ -2,10 +2,10 @@ AM_CFLAGS = -I$(srcdir) -O2
 AM_LDFLAGS = -llttng-ust
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 noinst_PROGRAMS = gen-events
@@ -14,3 +14,17 @@ gen_events_LDADD = -llttng-ust -lurcu
 
 noinst_SCRIPTS = test_low_throughput
 EXTRA_DIST = test_low_throughput
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023822 seconds and 4 git commands to generate.