Clean-up: modernize pretty_xml.cpp
[lttng-tools.git] / tests / regression / ust / low-throughput / Makefile.am
index 95022b9f98e9ede50fe48d9cf1722a6efd3077d6..5e688c56d04a3016077eacae1e008976a2b912b5 100644 (file)
@@ -1,8 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(srcdir)
 
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 noinst_PROGRAMS = gen-events
 gen_events_SOURCES = main.c tp.c tp.h
-gen_events_LDADD = -llttng-ust -lurcu $(DL_LIBS)
+gen_events_LDADD = $(UST_LIBS) $(DL_LIBS)
 
 noinst_SCRIPTS = test_low_throughput
 EXTRA_DIST = test_low_throughput
This page took 0.023232 seconds and 4 git commands to generate.