Clean-up: modernize pretty_xml.cpp
[lttng-tools.git] / tests / regression / ust / low-throughput / Makefile.am
index 8ce8f24397eae0a4d358a9f623bd1c738ca3c529..5e688c56d04a3016077eacae1e008976a2b912b5 100644 (file)
@@ -1,15 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(srcdir)
 
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-LIBS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-LIBS += -lc
-endif
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
 
 noinst_PROGRAMS = gen-events
 gen_events_SOURCES = main.c tp.c tp.h
-gen_events_LDADD = -llttng-ust -lurcu
+gen_events_LDADD = $(UST_LIBS) $(DL_LIBS)
 
 noinst_SCRIPTS = test_low_throughput
 EXTRA_DIST = test_low_throughput
This page took 0.025577 seconds and 4 git commands to generate.