Fix: Don't override user variables within the build system
[lttng-tools.git] / tests / regression / ust / high-throughput / Makefile.am
index 544640469df393feb7ed069564767311a615fe9f..22a31e18b062df7f43b6ec27e08199e2fc09dda0 100644 (file)
@@ -1,11 +1,10 @@
-AM_CFLAGS = -I$(srcdir) -O2
-AM_LDFLAGS = -llttng-ust
+AM_CPPFLAGS += -I$(srcdir)
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
-AM_LDFLAGS += -ldl
+LIBS += -ldl
 endif
 if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-AM_LDFLAGS += -lc
+LIBS += -lc
 endif
 
 noinst_PROGRAMS = gen-events
@@ -14,3 +13,17 @@ gen_events_LDADD = -llttng-ust
 
 noinst_SCRIPTS = test_high_throughput
 EXTRA_DIST = test_high_throughput
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(EXTRA_DIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024586 seconds and 4 git commands to generate.