Fix: Don't override user variables within the build system
[lttng-tools.git] / tests / regression / ust / getcpu-override / Makefile.am
index f1026ac02e96417b946d6af33d01cacda7974f07..a6487d9bb7f6ce9c6d939b282bd3afa8927d04aa 100644 (file)
@@ -1,4 +1,14 @@
-AM_CPPFLAGS = -I$(srcdir)
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+
+CLEANFILES = lttng-ust-getcpu-override-test.so \
+       lttng-ust-getcpu-override-test.so.debug
+
+EXTRA_DIST = test_getcpu_override run-getcpu-override \
+       lttng-ust-getcpu-override-test.c
+
+else
 
 # The rpath is necessary because libtool won't build a shared library
 # if it's noinst_
@@ -11,6 +21,7 @@ GETCPU_LIBTOOL_FLAGS = \
 
 noinst_LTLIBRARIES = lttng-ust-getcpu-override-test.la
 lttng_ust_getcpu_override_test_la_LDFLAGS = $(GETCPU_LIBTOOL_FLAGS)
+lttng_ust_getcpu_override_test_la_SOURCES = lttng-ust-getcpu-override-test.c
 
 if LTTNG_TOOLS_BUILD_WITH_LIBDL
 lttng_ust_getcpu_override_test_la_LIBADD = -ldl
@@ -35,3 +46,5 @@ clean-local:
                        rm -f $(builddir)/$$script; \
                done; \
        fi
+
+endif
This page took 0.023618 seconds and 4 git commands to generate.