Clean-up: modernize pretty_xml.cpp
[lttng-tools.git] / tests / regression / ust / getcpu-override / Makefile.am
index a7bdc86cdd68af5dc562fa96ef9c76458eb16882..0c04961ec48917c6660a3619611c7874027a1863 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 if NO_SHARED
 # Do not build this test if shared libraries support was
 # explicitly disabled.
@@ -10,26 +12,19 @@ EXTRA_DIST = test_getcpu_override run-getcpu-override \
 
 else
 
-AM_CPPFLAGS = -I$(srcdir)
-
 # The rpath is necessary because libtool won't build a shared library
 # if it's noinst_
 GETCPU_LIBTOOL_FLAGS = \
     -module \
     -shared \
     -avoid-version \
-    --no-as-needed \
+    -Wl,--no-as-needed \
     -rpath $(abs_builddir)
 
 noinst_LTLIBRARIES = lttng-ust-getcpu-override-test.la
 lttng_ust_getcpu_override_test_la_LDFLAGS = $(GETCPU_LIBTOOL_FLAGS)
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-lttng_ust_getcpu_override_test_la_LIBADD = -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-lttng_ust_getcpu_override_test_la_LIBADD = -lc
-endif
+lttng_ust_getcpu_override_test_la_SOURCES = lttng-ust-getcpu-override-test.c
+lttng_ust_getcpu_override_test_la_LIBADD = $(DL_LIBS)
 
 noinst_SCRIPTS = test_getcpu_override run-getcpu-override
 EXTRA_DIST = test_getcpu_override run-getcpu-override
This page took 0.023569 seconds and 4 git commands to generate.