Import CStringView from the Babeltrace tree
[lttng-tools.git] / tests / regression / ust / fork / Makefile.am
index 2c79db658f30852c3c7d03bbb31764ecaf9b5e45..e01bd5d8edd99c940e065f558648fd5e552dca06 100644 (file)
@@ -1,11 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(srcdir)
 
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 noinst_PROGRAMS = fork fork2
 fork_SOURCES = fork.c ust_tests_fork.h
-fork_LDADD = -llttng-ust -llttng-ust-fork $(DL_LIBS)
+fork_LDADD = $(UST_LIBS) -llttng-ust-fork $(DL_LIBS)
 
 fork2_SOURCES = fork2.c
-fork2_LDADD = -llttng-ust -llttng-ust-fork $(DL_LIBS)
+fork2_LDADD = $(UST_LIBS) -llttng-ust-fork $(DL_LIBS)
 
 noinst_SCRIPTS = test_fork test_fork.py
 EXTRA_DIST = test_fork test_fork.py
This page took 0.02638 seconds and 4 git commands to generate.